Skip to content
重建大师帮助GET3D Professional

本页内容

4 工程与主界面​

重建大师的主界面由菜单栏、账户信息、流程栏、工程列表、工作区和状态栏组成,如下图所示。

图 14 主界面

图 14 主界面

  • ①菜单栏:工程、区块、设置、工具、帮助五个菜单。

  • ②账户信息:显示当前用户名和授权类型。

  • ③流程栏:显示建模的四个步骤:添加照片、空三、重建、产品。

  • ④工程列表:以树状形态列出工程中的数据管理、区块、重建和产品,单击后在工作区打开。

  • ⑤数据管理界面:对导入的数据进行分块和管理。

  • ⑥状态栏:显示任务目录和引擎状态,可启动本地引擎。

4.1 菜单栏​

菜单栏包括【工程】【区块】【设置】【工具】【帮助】5 个菜单,下面按菜单顺序说明各菜单项;需要多步操作的菜单项,在所属菜单下单独说明。

4.1.1 工程​

工程菜单用于新建、打开、保存、清理和关闭工程,如下图所示。

图 15 工程菜单

图 15 工程菜单

各菜单项的说明见下表。

表 3 工程菜单

名称

快捷键

说明

新建工程

Ctrl+N

在指定目录下新建工程

打开工程

Ctrl+O

打开已有工程(.m3d 文件)

保存工程

Ctrl+S

保存当前工程

清理工程

—

删除当前工程的缓存和中间文件,操作方法见本表后的“清理工程”

关闭工程

—

关闭当前工程

结束

Ctrl+W

关闭当前工程并退出软件

最近工程

—

显示最近打开的 8 个工程

清理工程

工程处理完成后或磁盘空间不足时,用此功能删除缓存和中间文件,释放磁盘空间,减小工程备份所需的空间。清理后保留原有工程目录结构和空三成果。

操作步骤:

  1. 点击【工程】>【清理工程】,打开【清理工程】窗口。

  2. 在【清理文件选择】中选择要清理的文件类型,如:工程缓存、区块缓存、重建缓存、重建瓦片中间文件或产品日志。每次选择一种。

  3. 在下方列表中勾选要清理的对象;勾选【所有】可全部选中。

  4. 在右侧【所选清理文件】中核对待清理的目录和大小,点击【开始清理】。

图 16 清理工程窗口

图 16 清理工程窗口

完成后,所选文件被删除。窗口右侧的【工程信息】显示工程路径和磁盘空间使用情况。

注意:

• 任务运行过程中工程磁盘空间不足时,可清理工程缓存、区块缓存和重建缓存。清理后,任务所需的缓存会重新生成,可能降低处理效率,但不会导致任务失败,也不会影响处理结果。

• 最终清理前,请确认数据处理已全部完成,并已导出和备份空三成果、空三报告、成果模型等交付物。

4.1.2 区块​

区块(Block)指空三区块。区块菜单用于保存、导入和导出区块,导出展点图,以及修改照片路径,如下图所示。

图 17 区块菜单

图 17 区块菜单

各菜单项的说明见下表:

表 4 区块菜单

名称

说明

保存区块

保存对区块的修改,如编辑相机参数和照片 pose、删减照片和连接点,保存后修改生效

导入区块

导入外部空三成果,支持 XML(BlocksExchange 通用交换格式)和 XBIN

导出区块

导出空三成果、无畸变影像、位姿和照片,详见“7.5 导出区块”

导出展点图

导出区块中照片 pose 点位的平面分布图,操作方法见本表后的“导出展点图”

照片路径修改

照片存放位置变化后,修改区块中的照片路径,详见“6.3.3 照片路径修改”

打开区块目录

打开存放工程文件、缓存和报告的目录

导出展点图

用此功能导出区块中照片 pose 点位的平面分布图。图中同时显示控制点,可用于查看照片分布和控制点位置。

操作步骤

  1. 选中区块,点击【区块】>【导出展点图】,打开【导出区块展点图】窗口。

  2. 在窗口中预览展点图,点击【导出展点图】。导出格式为 JPG 或 PDF。

图 18 导出区块展点图窗口

图 18 导出区块展点图窗口

图 19 区块展点图示例

图 19 区块展点图示例

4.1.3 设置​

设置菜单的内容与 GEngine 相关,GEngine 的设置方法详见“12.3 GEngine设置”。

图 20 设置菜单

图 20 设置菜单

4.1.4 工具​

工具菜单提供瓦片匀色、格式转换、生成快拼 DOM、轨迹线文件检查合并、合并 DOM/DSM 和模型原点规划等工具,如下图所示。

图 21 工具菜单

图 21 工具菜单

各菜单项的说明见下表。

表 5 工具菜单

名称

说明

瓦片匀色

消除二维网格划分生产的瓦片之间的色差,详见“11.4 瓦片匀色”

格式转换工具

将已完成重建的模型产品转换为其他格式,详见“11.5 格式转换工具”

生成快拼DOM

用已完成空三的区块直接生成快拼 DOM,详见“11.2 生成快拼DOM”

航迹线检查合并

检查并合并多条轨迹线文件,详见“11.6 航迹线检查合并”

合并DOM/DSM

将分幅的 DOM/DSM 合并为一幅图像,详见“11.3 合并DOM/DSM”

模型原点规划

为大范围模型规划多个模型原点,并联动重建阶段按多原点设置输出,详见“11.1 模型原点规划”

4.1.5 帮助​

帮助菜单用于查看用户手册、更新说明和版本信息,打开日志和 Dump 目录,以及反馈问题和检查软件更新。各菜单项的说明见下表。

表 6 帮助菜单

名称

说明

用户手册

打开本手册

更新操作说明

查看版本更新内容

关于

查看版本号、发布日期等信息

日志目录

打开软件运行日志所在的目录

Dump目录

打开软件崩溃时生成的 Dump 文件所在的目录

问题反馈

导出当前工程的参数、日志和报告,反馈问题,操作方法见本表后的“问题反馈”

检查更新

查看并下载可用更新,操作方法见本表后的“软件更新”

提示:软件在正常使用中崩溃时,可将 Dump 目录中的 Dump 文件发送给技术支持。

问题反馈

软件运行异常或处理结果不理想时,用此功能一键导出当前工程的参数设置、处理日志和相关报告,发送给技术支持排查问题。

操作步骤

  1. 点击【帮助】>【问题反馈】。

图 22 问题反馈入口

图 22 问题反馈入口

  1. 扫描二维码加入官方企业微信群,或通过邮件联系技术支持。

图 23 扫码进群或发邮件

图 23 扫码进群或发邮件

  1. 点击窗口中的蓝色链接文字,打开导出反馈数据界面。

图 24 打开导出反馈数据界面

图 24 打开导出反馈数据界面

  1. 选择问题类型:界面问题无需导出日志;空三和重建问题可在下拉框中选择对应的区块和产品,然后点击导出。

图 25 选择问题类型并导出图 25 选择问题类型并导出

图 25 选择问题类型并导出

  1. 将导出的文件通过邮件或企业微信群发送给技术支持。

软件更新

本功能仅适用于重建大师专业版(GET3D Professional)。可在软件中检查可用版本、下载更新包并重启安装。

在可联网的电脑上操作,更新前保存当前工程。

1. 点击【帮助】>【检查更新】。

检查软件更新入口

图 26 检查软件更新入口

2. 检测到可用版本后,在【软件更新】窗口查看版本号和更新说明,点击【确认】开始下载。

确认可用版本并开始下载

图 27 确认可用版本并开始下载

3. 在主界面右下角查看下载进度。显示“更新包下载完成”后,点击【重启并安装】。

下载进度与重启安装入口

图 28 下载进度与重启安装入口

4. 进入【G3D软件更新程序】后,保持窗口打开,等待更新完成。

应用软件更新时保持窗口打开

图 29 应用软件更新时保持窗口打开

5. 更新完成后,在软件中点击【帮助】>【关于】,核对版本信息。

提示:图中的版本号、更新内容和进度值仅为示例,请以实际界面为准。

4.2 账户信息​

主界面右上角显示当前登录的用户名和授权类型。授权分为正式授权和试用授权,获取方法详见“2.4.3 获取授权”。

图 26 账户信息窗口

图 30 账户信息窗口

4.3 流程栏​

流程栏按顺序显示 1-添加照片、2-空三、3-重建、4-产品四个步骤。在工程列表中选中某项内容时,流程栏高亮该内容所属的步骤及之前的步骤。例如,选中已完成空三的区块时,高亮“1-添加照片”和“2-空三”。

图 27 流程栏

图 31 流程栏

4.4 工程列表​

工程列表以树形显示工程中的内容:【数据管理】是数据管理界面的入口;工程名称下列出当前工程的区块,单击区块,工作区切换到该区块的页面。每次空三生成的新区块(如 Block_1-AT)、区块下的重建和重建下的产品也列在其中。

工程右键菜单

在工程名称上单击右键,菜单如下图所示。

图 28 工程右键菜单

图 32 工程右键菜单

  • 【导入区块】:导入 BlocksExchange XML 格式的空三成果,导入的空三可以直接用于重建;

  • 【新建区块】:软件提示并跳转到数据管理,在其中划分区块。

区块状态

区块名称前的图标表示区块的处理状态,共 5 种:成功—绿色对勾,取消—灰色横线,失败—红色叉号,运行中—蓝色箭头,等待—橙色时钟,如下图所示。

图 29 区块状态图标

图 33 区块状态图标

区块右键菜单

在区块上单击右键,菜单如下图所示。

图 30 区块右键菜单

图 34 区块右键菜单

  • 【导出】:子菜单如下图所示,包括:

图 31 导出子菜单

图 35 导出子菜单

  • 【区块】:导出空三成果,详见“7.5 导出区块”;

  • 【区块展点图】:导出区块中照片 pose 点位的平面分布图,操作方法见菜单栏“区块”菜单中的“导出展点图”;

  • 【Pos多边形】:根据照片的 pose 自动生成外轮廓多边形,导出为 KML 文件。下面两图分别为照片的 pose 分布和导出的多边形。

图 32 左 - 照片的 pose 分布,右 - 导出的 Pos 多边形图 32 左 - 照片的 pose 分布,右 - 导出的 Pos 多边形

图 36 左 - 照片的 pose 分布,右 - 导出的 Pos 多边形

  • 【复制区块】:复制当前区块,生成区块副本(名称后加“-Copy”);

  • 【打开区块目录】:打开存放区块文件、缓存和报告的目录;

  • 【空三优化】:见《空三设置》文档;

  • 【重命名】【删除】:修改区块名称,或删除区块;

  • 【新建重建-2D】【新建重建-3D】【新建重建-3DGS】:在该区块上新建二维、三维或三维高斯重建,详见“第 9 章 重建”。

重建右键菜单

在重建上单击右键,可新建产品、重置重建、复制重建、导出KML、打开重建目录、保存、删除和重命名,详见“第 9 章 重建”。

4.5 数据管理界面​

工作区的内容随工程列表中的选择变化:

4.6 状态栏​

状态栏左侧显示任务目录、引擎数和运行的引擎数。【打开文件夹】打开任务目录,【修改目录】修改任务目录;另有【刷新】、【查看任务执行】、【启动本地引擎】按钮。右侧提示引擎状态,如“引擎已启动”;引擎未启动时,点击【启动本地引擎】。提交空三和重建等任务前,确认这里提示引擎已启动。

搜索全部帮助